Problemas con el proxy-caché de Telefónica y páginas html con formulario tipo POST

Base de conocimiento de la plataforma de desarrollo Velneo

Moderador: vCoaches

Responder
vBdC
vGuru
vGuru
Mensajes: 2
Registrado: 11 Oct 2005, 14:22

Problemas con el proxy-caché de Telefónica y páginas html co

Mensaje por vBdC » 10 Dic 2003, 01:00

Problemas con el proxy-caché de Telefónica y páginas html con formulario tipo POST

Categorías: Html, VATP/HTTP, Configurar router

Palabras clave: Post, Get

Enunciado:
Cuando uso un formulario de html con el comando POST tenemos problemas con el proxy-caché de Telefónica.

Desarrollo:
El servidor HTTP de Velázquez Visual contempla el método POST pero el protocolo HTTP 1.1 (usado por el proxy-caché de telefónica) tiene una variante de este método que no contempla el Servidor.

Cambiando el método del formulario de POST a GET, desaparece el problema, pero la seguridad de nuestras aplicaciones se verá vulnerada.

Como alternativa, para los servicios web podemos establecer la comunicación entre el router y el exterior por un puerto distinto al 80. Lo que debemos hacer es, en el caso de que el puerto de escucha del Servidor HTTP siga siendo el puerto 80, redireccionar en el router todo lo que le llegue por el puerto con el que vaya a establecer la comunicación (por ejemplo el 81) al 80, que es en el que está escuchando el Servidor. Por otra parte, desde las estaciones cliente se comunicará con el Servidor cuando necesite usar formularios POST escribiendo: http:// IP: 81.



Artículos relacionados
Cómo acceder a un Servidor de Aplicaciones que está detrás de un router
Última edición por vBdC el 10 Dic 2003, 01:00, editado 1 vez en total.

Responder