Ficha no se refresca nunca para un enganche, sí para otros

vForum público de la plataforma de desarrollo Velneo

Moderador: vCoaches

mcventur
vRookie
vRookie
Mensajes: 16
Registrado: 27 Oct 2009, 19:15

Ficha no se refresca nunca para un enganche, sí para otros

Mensaje por mcventur » 05 Ago 2015, 16:16

Buenas gente.
Estoy experimentado un problema peliagudo con una ficha. Al hacer el alta de ficha, en el proceso posterior a alta le añado por proceso unos históricos que disparan unas actualizaciones hacia la propia ficha. Simplemente para llevar dos contadores de históricos. Esa modificación del contador de históricos provocada por la actualización desde históricos hace a su vez que se dispare en el previo a modificación de la ficha maestra un recálculo de otro campo, una especie de estado.
La cuestión es que me ocurre algo raro:
- Al hacer un alta, desde el enganche en que la ejecuto, espero y espero, pero ni el contador ni el campo a recalcular muestran valor alguno.
- Sin embargo, sin cerrar siquiera el enganche que hizo el alta, abro otro enganche del mismo usuario y accedo a la rejilla de maestros y a la ficha en cuestión y veo el contador actualizado, y el campo a recalcular también.
- Después de esto, salgo y entro varias veces en la rejilla (Una busqúeda por codigo para mostrar todos) de maestros desde el primer enganche y sigo viendo el contador y el campo a recalcular sin valor. Y al abrir la ficha lo mismo.

Alguien me puede explicar qué ocurre? Dos enganches distintos ven valores distintos para una misma ficha...

Responder