Problemas para mandar datos SOAP/XML / Urgente

vForum público de la plataforma de desarrollo Velneo

Moderador: vCoaches

Responder
JJBA
vMate
vMate
Mensajes: 54
Registrado: 10 Dic 2006, 20:33

Problemas para mandar datos SOAP/XML / Urgente

Mensaje por JJBA » 20 Oct 2007, 18:56

Tengo que enviar un documento XML bajo SOAP a un servicio web bajo conexión segura HTTPS.
Es la primera vez que lo hago, necesitaria una gran ayuda, no tengo ni idea, si es posible por favor contactar alguien conmigo, o mandarme un archivo de ayuda.Gracias

Tengo que mandar por ejemplo este formato.

<SOLICITUDES>
<ID>98345</ID>
<SOLICITUDES>

este es el formato mas sencillo.


jjbajuan@telefonica.net :cry:

JJBA
vMate
vMate
Mensajes: 54
Registrado: 10 Dic 2006, 20:33

No hay nadie que pueda echarme una mano

Mensaje por JJBA » 22 Oct 2007, 17:46

:evil:

jluisgf
vRookie
vRookie
Mensajes: 6
Registrado: 19 Jul 2006, 10:49
Ubicación: Porriño

A ver si te puede ayudar este antiguopost mio que te indico.

Mensaje por jluisgf » 23 Oct 2007, 15:20

http://forum.velneo.com/es/viewtopic.ph ... ight=https

Yo ya tuve este mismo problema y lo resolví creando desde velneo un jscript que se monta en un componente html, lo graba como un fichero .js en disco y después lo ejecutas.
El jscript utiliza el API WinHttp de Microsoft tal y como comento en dicho post.

El tema es que en las pruebas nos fué bien pero después no tuvimos que usarlo y dejamos abandonado el tema, y no me acuerdo muy bien como funciona y no tengo demasiado tiempo para pararme a verlo.

Te adjunto un mapa donde he incluido creo que todos los objetos que uso en el tema y he extirpado a correr cosas muy propias. Tendrá errores pero supongo que algo te orientará.

La tabla ENV-EDI es donde guardo todos los envios realizados mediante comunicaciones (sea edi o cualquier otro medio) y la DOC-SANID se supone que es de la que saco los datos que debo enviar.
Adjuntos
Mapa1.map
(19.84 KiB) Descargado 85 veces

JJBA
vMate
vMate
Mensajes: 54
Registrado: 10 Dic 2006, 20:33

Gracias por tu contestación

Mensaje por JJBA » 23 Oct 2007, 19:15

Primero muchas gracias, por el mapa ahora mismo me peleo con el, la verdad es que ando muy perdido con el tema, ya te contare y si merece la pena intentare poner algo en el foro :wink:

Responder