Aviso a navegantes: Expendiente X en formularios de búsqueda

vForum para suscriptores profesionales de la plataforma de desarrollo Velneo

Moderador: vCoaches

Responder
Avatar de Usuario
Fran
vCoach
vCoach
Mensajes: 6599
Registrado: 21 Sep 2005, 08:23
Ubicación: Madrid (España)
Contactar:

Aviso a navegantes: Expendiente X en formularios de búsqueda

Mensaje por Fran » 27 Oct 2007, 21:43

Buenas noches:

Escribo este post para contaros un expediente X que me ha sucedido recientemente y que me ha hecho perder un rato dando vueltas.

El caso es que tenía un form de búsqueda para pedir los parámetros de una ídem. Le añadi un edit con su correspondiente menú contextual y el botón que disparaba el localizador (para añadirle un parámetro más a la búsqueda) copiando y pegando los objetos de otro form.

El comportamiento era el siguiente: Al pulsar el botón del menú contextual para abrir el localizar, no se abría y se disparaba la búsqueda, como si hubiese pulsado el botón de Buscar.

Si me posicionaba sobre el edit y pulsaba el acelerador de teclado asociado al botón, si se presentaba correctamente.

Estuve un buen rato dando vueltas y no encontraba la solución. Al final me di cuenta de casualidad, cuando se me ocurrió ampliar ligeramente el tamaño del form de búsqueda.
Al hacer esto, el formulario se hizo mucho más grande... porque el botón contextual oculto que había pegado del otro form estaba fuera de los límites del nuevo form!!!

Desplacé el botón oculto dentro de los límites del form y volví a dejarlo en su tamaño original: El funcionamiento pasó a ser el normal.

Este expediente X me ha hecho perder un buen rato revisando del formulario de búsqueda de arriba a abajo (varias veces). Si a alguien le pasa esto mismo, que se acuerde de comprobar el tema de los botones. :cry:
Un saludo,

Francisco Javier Pérez Novo
EfeUno Consultores de Gestión y Software, S.L.
fjpnovo@efeuno.org
http://www.efeuno.org
(+34) 91 519 44 86
Skype: Fran-EfeUno

Google Maps:
40.447943147972445, -3.6719655990600586

Avatar de Usuario
jarboleya
Velneo
Mensajes: 95
Registrado: 03 Jul 2007, 13:55

Mensaje por jarboleya » 29 Oct 2007, 00:45

Gracias Fran,

Supongo que lo has comprobado desde todos los ángulos posibles y, conociéndote seguro que lo has enviado a soporte.

Lo mejor es que una vez comprobado se añada a la base del conocimiento para que todos puedan encontrarlo con facilidad.

Muchas gracias por tu aportación.
Opinión personal de jarboleya no vinculante a Velneo
Velneo
Life is Soft
http://jarboleya.com

Responder